Jostle's platform is currently unavailable
Incident Report for Jostle - EU
Resolved
Jostle's platform is available again.
Posted May 14, 2020 - 07:08 PDT
Investigating
We are currently investigating and will update status when information is available.
Posted May 14, 2020 - 07:07 PDT