Jostle issue
Incident Report for Jostle - EU
Resolved
Closing Maintenance
Posted Jul 28, 2022 - 02:44 UTC
Investigating
Jostle's universal search has limited functionality because the third-party technology that backs his service is currently down. We are monitoring the situation and will restore service when they do.
Posted Jul 27, 2022 - 17:56 UTC